Hire a senior Perl / Python programmer today; download my up-to-date resume (PDF)
John Bokma MexIT
freelance Perl programmer

Comments: Installing VirtualBox PUEL edition on Ubuntu

6 comments

Over two years ago I created my first virtual machine running Windows XP. Back then I used the free VMware Player running on Windows XP. Nowadays, my main development operating system is Ubuntu 8.10 most of the time. Yet, for some projects I still have to fall back to Windows XP. VirtualBox had been for quite some time on my "must check out" list, and today I finally was able to make time to install VirtualBox Personal Use and Evaluation License (PUEL).

Read the rest of Installing VirtualBox PUEL edition on Ubuntu.

Comments

I love you !!

Works perfectly for me. Very well explained.

Thanks again.

:D

Posted by Mr Surbade at 10:37 GMT on 20 January 2009

Hi!

I'm using an intrepid server. I've tried the included 2.0.4 release, but I got all the time the VERR_VM_DRIVER_NOT_INSTALLED (rc=-1908) error.

After a bit of research I got here and tried the solutions (the '/etc/init.d/vboxdrv setup' with no luck... it said only start|stop|... but it won't accept 'setup'; BTW, DKMS seems to be installed by default here).

Then I've tried with the PUEL version as your page guides. Same problem, BUT the installer gave me a hint... "maybe you don't have the sources"... so I went to the Synaptic and added the linux-headers-xxx of my kernel... then reinstalled the vbox and... voilą

Thanks for your guide!

Posted by djago at 03:39 GMT on 10 March 2009

You're welcome, djago. And thanks for the additional information. I can't recall that I explicitely installed the Linux headers, but if they are required, I guess they got installed when I installed some other piece of software earlier on.

Posted by John Bokma at 20:21 GMT on 10 March 2009

omg.. ty so much ^-^ ..

Posted by sora at 07:06 GMT on 12 March 2010

Thx, very helpful! I have had a hard time installing VirtualBox on Ubuntu.

Posted by jay at 12:59 GMT on 7 February 2011

Hey I'm using Ubuntu 10.04 LTS ... and everytime I try the install command on the terminal, I get this "Package virtualbox-2.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package virtualbox-2.0 has no installation candidate"

Help please?

Posted by Anonymous at 18:17 GMT on 7 August 2011

Post a comment

Note that your comment doesn't show up immediately. I review each comment before I add it to this site.

Check the Follow this page option if you want to receive an email each time a comment is posted to this page, including yours. A link to turn this option off will be included with each email.

Internet adresses will be converted automatically. You can use the following notation to specify anchor text for a link: [url=http://example.com/]example text[/url].